Contribute to Open Source. Search issue labels to find the right project for you!

KDB Export: Support Multiple Plugins



Currently plugins that require other plugins might crash on export. The issue is that kdb export only supports a single plugin. The commands below show steps to reproduce a crash.

cd src/plugins/xmltool/xmltool
kdb import user/tests/dump xmltool < dump.xml
kdb export user/tests/dump tcl
#> {
#>        {
# STDERR: *** Error in `kdb': munmap_chunk(): invalid pointer: 0x000000000119c490 ***
#                 zsh: abort (core dumped)  noglob kdb export user/tests/dump tcl

This issue should be fixed after we implement #1229.

Updated 17/10/2017 09:35

Gestion d'un panier

  • Décider si le stockage doit se faire en session (cookie, local storage, …) ou en base de données par utilisateur ;
  • Mettre à jour le menu de la page pour afficher le panier ;
  • Insérer le panier entre la recherche et la réservation
Updated 17/10/2017 09:24

Add tooltips to QuickGrid

  • Grid cells, Header, Action cells and Footer now have tooltips enabled by default
  • cell tooltip shows cell data, action cell tooltip shows actions tooltip
  • tooltips can be disabled via tooltipsEnabled prop in QuickGrid
  • action cells (column) tooltip can be passed via actionsTooltip prop in QuickGrid
  • cells that have their own formatter function have to take of the tooltip on their own
Updated 17/10/2017 09:21

Simplify and unify hazelcast-code-samples


I would like to open discussion about simplifying and unifying code samples. The idea behind is to provide unified experience to users and allow QE to verify the samples in a CI job.

Suggested improvements: * use one main class per sample and unify its name across the samples (e.g., so the maven-exec-plugin can be configured in the parent POM and users can use mvn exec:java in each sample * shut down the whole cluster at the end of each sample * remove shell scripts - the maven-exec-plugin shall be used instead (lets provide where necessary) * use System.out to print what the samples do * it will allow to introduce basic test automation in Jenkins

We should also think about slimming down the samples - i.e. find candidates for a removal. We have 214 modules with 312 main classes included now. Such amount is not easy to maintain. I would prefer to have 100 main classes at most.

Comments and suggestions for other improvements are welcome.

Updated 17/10/2017 09:35 1 Comments

Create add book page


We need to create a route so that admins can add books to the library, we need to do this first so that we don’t have to manually add things to the database.

Once we add login then this will be a protected, admin only route, but for now we’ll just have it on a particular url.

Updated 17/10/2017 09:30 1 Comments

Creare pagina orari aule


Questa pagina contiene gli orari delle varie aule dell'università, che possono essere filtrati per aula o per orario (incluso un tasto “orario corrente” o qualcosa del genere). I dati vengono presi dall'università, in qualche modo che non abbiamo ancora previsto al 100%.

Updated 17/10/2017 09:24



Come utente voglio che l'applicazione mi mandi una notifica in caso sia in ritardo per un pullman che mi sono impostato come pullman da prendere

HTD: ci deve essere un tasto nel menu che attiva/disattiva la possibilità di ricevere notifiche tramite l'applicazione

Updated 17/10/2017 09:15

We should check if we can simplify the extension registration process at some point.


The current process of registering the decompiler extensions uses an adapter mechanism, we could check at some point if we can simplify that by switching to a “simple” extension point on which “just” interface implementations are registered. That might reduce the code significantly and make it more maintainable.

Such an extension point is easily defined and, as far as I can see, would reduce the required.

Updated 17/10/2017 09:09

Update reward sign on agreement compensation mappings


Specifically: - [ ] Do not use absolute values for penalties neither rewards. - [x] On Property 1: Consistent Compensable Function: Change (p1 > p2 OR r1 < r2) by (p1 > p2 OR r1 > r2)

  • [x] On Property 2: Saturated Compensable Function Change r== max(domain®) by r== min(domain®)

  • [x] On Property 4: Consistent Compensable Function Change r > 0 AND NOT(SLO({m})) by r < 0 AND NOT(SLO({m}))

Updated 17/10/2017 09:09

Stalemate prevention measure


We had an idea to help reduce the constant neutral “lock” which has happened on various occasions.

This is the idea: If all active objectives are neutral, then the following happens…

The team with the least amount of objectives, if both teams tie, then the team with the least reinforcements has double the respawn time.

Requirements: We will need (probably need to anyways) indicate what is affecting the player’s respawn time on the hud while they are dead.

Updated 17/10/2017 09:05

Improve serialization format


At the moment, we serialize scripts into subclasses of ViScriptArchive, which has the granularity of a profile and its organization. A script can have a category to support extensions in the Monticello sense. Thus, version management via such code objects works with MC and FileTree.

A possible improvement could be to re-design serialization modules towards tool boundaries. A tool is usually some scripts, views, view configurations, and objects. A bundle in the form of a single class with some methods seems reasonable. Multiple such tools could form multiple classes in the same package. Hmm… view configurations might be better off in their own subclasses. Example (input) objects could be serialized in a SmartRefStream or JSON or …

Updated 17/10/2017 09:03

Allow to map UID and GID for Docker shared volume binding


Currently if user mounts a shared folder into Docker ASF container via -v /home/archi/ASF/config:/app/config directive, the container’s ASF instance writes into that folder as host’s root user (all files and folder are owned by root:root)

Other docker images solve this by means of a configurable environmental variable GID and UID mapping via -e option (for example all maintained images - like It would be great if it was possible to do this for ASF docker image as well!

Updated 17/10/2017 09:29 1 Comments

Add function identities to the dyadic function lookup table


The reduce and scan operators need to know what the identify of each dyadic function is. For + and ×, the identity is 0 and 1.

The identity may be determined by applying reduce to zilde.

For non-mathematical functions, the identity is expected to be zilde but this needs to be confirmed.

At run time, the identity will be determined by lookup. It seems sensible to use the existing lookup table by adding another field.

A test per function in tests/ will be needed.

An analogous test of scan with zilde should also be added. For mathematical functions, this is expected to yield zilde and for non-mathematical operations to throw value error. To be confirmed.

Updated 17/10/2017 08:56

Experiment with GraphQL endpoint


Here’s why GraphQL might be a good thing for us:

  • Return collections, and authors, on entity and document search results upon demand.
  • Filter by more attributes, fully dynamic, without our own filter: DSL

What I find difficult to gauge so far:

  • How best to encapsulate result set metadata, especially facets
  • How to make sure we do proper authz for write access

cc @wpf500

Updated 17/10/2017 08:47

Add ev_demand to datadump "loads"


Our client wants to reproduce the dynamic demand chart.

The “loads” export gives 3/5 components of this chart:

In “loads” export: total_demand, fever_hot_water, fever_space_heating Not in “loads” export: merit_ev_demand, other

If merit_ev_demand (MERIT_DEMAND_COMPONENT(ev_demand)) is also added to the “loads” export a user has all the information to reproduce this chart themselves.

@antw can this be added to the data export?

Updated 17/10/2017 08:42

Encapsulate update actions emptiness check in update service


As an improvement to simplify the implementation of the sync processes in,, etc.. When building update actions, instead of checking if the update actions list is empty and calling the update service, the service itself should do the check. This has two advantages:

  1. Simplify implementation in sync process.
  2. Delegate the responsibility of the emptiness check from the user of the service to the service itself, so that not every user of the service has to check before calling update, but the service itself does it for all callers.
Updated 17/10/2017 08:42

Add overlap option for cone search


In Gammapy we currently call healpy.query_disc with both the inclusive=True and the inclusive=False option (see

As discussed in , probably we don’t want to spend the time to fully implement healpy.query_disc concerning the inclusive=False behaviour.

But maybe we could add an option to HEALPix.cone_search_lonlat that corresponds to the inclusive=True behaviour, i.e. restricts the pixels to the ones where the center is in the cone?

@astrofrog - OK to add this?

How about calling it overlap={'center', 'full'} which is maybe a bit more intuitive than inclusive = {True, False} and also more extensible should we want to add other options in the future? Concerning implementation: should it just be done at the end of the function in an if overlap == 'center' block using a Numpy expression, subsetting with a mask that’s true if the pixel center is in the cone? Or would you suggest this be added in the C or Cython code somehow?

Updated 17/10/2017 09:35 1 Comments

Fork me on GitHub